Welcome Guest! To enable all features please Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline Itsjack  
#1 Posted : 04 October 2019 20:38:02(UTC)
Itsjack


Posts: 2

Hi guys!
Strange one.

I have a Megane 4 RS 300 trophy.
And recently the exhaust has stopped popping as much now I’m sport mode,not as loud and just rumbles and doesn’t pop?

I have shell V-Power in it at the moment.
Any ideas?
Offline CraigI  
#2 Posted : 04 October 2019 21:29:38(UTC)
CraigI


Posts: 983

Problem with the valve?
I use a mix of Tesco Momentum and V-Power and it pops and bangs on lift off all the time.
Offline Rolo  
#3 Posted : 05 October 2019 11:17:19(UTC)
Rolo


Posts: 122

Originally Posted by: Itsjack Go to Quoted Post
Hi guys!
Strange one.

I have a Megane 4 RS 300 trophy.
And recently the exhaust has stopped popping as much now I’m sport mode,not as loud and just rumbles and doesn’t pop?

I have shell V-Power in it at the moment.
Any ideas?


I reckon the valve is stuck. As I mentioned in a previous post, I had a drive in a Trophy at Silverstone in May & the valve was stuck closed. The exhaust was very muted, no pops & bangs, a lot less dramatic than my RS280!!
Offline Repair&Restore  
#4 Posted : 07 October 2019 20:35:57(UTC)
Repair&Restore


Posts: 158
Location: Trying to keep it clean !

You could always just fit a scorpion system with no valves to close
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.